Print Page | Close Window

[Risolto]Filtrare righe in base al valore di cella

Printed From: IALweb
Category: MS Office
Forum Name: Microsoft Excel
Forum Discription: Tutto sui fogli di calcolo e l'automazione d'ufficio
URL: https://forum.ialweb.it/forum_posts.asp?TID=16467476
Printed Date: 16/Giu/2019 at 03:24
Software Version: Web Wiz Forums 10.17 - http://www.webwizforums.com


Topic: [Risolto]Filtrare righe in base al valore di cella
Posted By: antoniomlg
Subject: [Risolto]Filtrare righe in base al valore di cella
Date Posted: 10/Ott/2018 at 18:33
salve sono nuovamente a chiedervi aiuto
come da titolo vorrei filtrare in un foglio i dati di altro foglio ma solo le righe che in una determinata cella hanno un valore nel esempio ho messo il numero 1 ma se deve essere una X non f importanza come non ha importanza nemmeno la sua posizione nella colonna E.

 situazione:
>nel foglio "Elenco Partecipanti" ho un elenco di nomi e nella colonna E metto il numero 1 per individuare
 chi ha diritto ad avere un buono pasto.

> nel foglio "Aventi Diritto" vorrei filtrare solo le righe che in colonna E riferita al foglio" Elenco Partecipanti" 
hanno il numero 1 nella rispettiva cella E.

ho provato ad usare la seguente formula (non frutto mio ma di altri) nel foglio "Aventi Diritto" celle B13,C13,D13
ma senza risultati, 

=SE.ERRORE(INDICE('Elenco Partecipanti'!B$2:B$143;AGGREGA(15;6;RIF.RIGA($B$2:$B$143)-1/('Elenco Partecipanti'!$E$2:$E$143=1);RIGHE($A$1:A1)));"")

ma non d nessun risultato.

la versione excel utilizzata 2007

grazie

uploads/17780/buoni_pasto_mensa.xlsx" rel="nofollow - uploads/17780/buoni_pasto_mensa.xlsx

 



Replies:
Posted By: dodo47
Date Posted: 11/Ott/2018 at 08:25
Ciao
la formula che ti hanno suggerito corretta, sei tu che la usi male.

E' una formula matriciale e, pertanto, va inserita con ctrl+shift+invio

saluti


-------------
domenico
win 10- office 2016


Posted By: antoniomlg
Date Posted: 11/Ott/2018 at 10:14
Grazie della conferma della formula esatta.
il problema non la formula bens la versione di excel utilizzata 
poich lo stesso file vine utilizzata anche in un pc che ha installato la versione di excel 
97-2003

non riesco ad adattarla.....

grazie


Posted By: dodo47
Date Posted: 11/Ott/2018 at 11:02
PROVA

SALUTI



uploads/17743/buoni_pasto_mensa_TEST.xlsx" rel="nofollow - uploads/17743/buoni_pasto_mensa_TEST.xlsx


-------------
domenico
win 10- office 2016



Print Page | Close Window

Forum Software by Web Wiz Forums® version 10.17 - http://www.webwizforums.com
Copyright ©2001-2013 Web Wiz Ltd. - http://www.webwiz.co.uk